Go Back  Buick Forum - Buick Enthusiasts Forums > General > New Member Area
Reload this Page >

PLEASE HELP !!!!!! DIM lights on Odometer / PRND321 Display - 03 Rendezvoux

New Member Area Are you new to Buick Forum?? WELCOME! Check in, tell us about yourself and your ride...

PLEASE HELP !!!!!! DIM lights on Odometer / PRND321 Display - 03 Rendezvoux

  #1  
Old 07-03-2013, 09:42 PM
Junior Member
Thread Starter
Join Date: Jul 2013
Posts: 1
Default PLEASE HELP !!!!!! DIM lights on Odometer / PRND321 Display - 03 Rendezvoux

Hi all,

First timer here...

The display containing the Odometer / PRND321 has gone Dim, sometimes is half as Dim, and sometimes when I tap on the cluster or there is a bump on the road it changes the light's intensity.

Does anyone have the fix for this?

This is what I have done already:
Removed cluster
Opened up unit - (Replaced stepper motors while I was at it)
Searched for a section with multiple resistors (as stated in other posts)
Attempted to re-solder (fix) the connection of those resistors
Tested the cluster -- Failed (same issue)
Re-soldered another set of resistors
Tested the cluster -- Failed (same issue)
Re-soldered ALL connections for the display (about 15 on bottom and 15 on top -- sorry did not count them)
Tested the cluster -- Failed (same issue)

I continued to check for solutions for Buick Rendezvoux (or any other GMC, chevy, Cadillac, etc) of a similar build and year but I found nothing applicable (older models have a different problem and therefore a different solution - or maybe the same problem but at a different point on the PCB)

ANYONE????

Thank you all !!
 
  #2  
Old 07-08-2013, 07:19 AM
Junior Member
Join Date: Jul 2013
Posts: 1
Default

Originally Posted by orale78 View Post
Hi all,

First timer here...

The display containing the Odometer / PRND321 has gone Dim, sometimes is half as Dim, and sometimes when I tap on the cluster or there is a bump on the road it changes the cheap hid headlight kits intensity.

Does anyone have the fix for this?

This is what I have done already:
Removed cluster
Opened up unit - (Replaced stepper motors while I was at it)
Searched for a section with multiple resistors (as stated in other posts)
Attempted to re-solder (fix) the connection of those resistors
Tested the cluster -- Failed (same issue)
Re-soldered another set of resistors
Tested the cluster -- Failed (same issue)
Re-soldered ALL connections for the display (about 15 on bottom and 15 on top -- sorry did not count them)
Tested the cluster -- Failed (same issue)

I continued to check for solutions for Buick Rendezvoux (or any other GMC, chevy, Cadillac, etc) of a similar build and year but I found nothing applicable (older models have a different problem and therefore a different solution - or maybe the same problem but at a different point on the PCB)

ANYONE????

Thank you all !!
Were you able to solve out the problem? I am facing similar one so if you have any good solutions please share.. Thanks in advance
 

Last edited by JesusLowe; 07-09-2013 at 01:43 AM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
steveinnepa
General Tech Help
3
10-10-2012 03:45 PM
Lord_Bryan
Century
6
12-22-2011 12:16 PM
jnlb
Century
11
10-27-2008 01:52 PM
dogthenine
General Tech Help
0
02-20-2007 09:23 PM
Dustydog
General Tech Help
0
01-21-2006 06:07 AM


Thread Tools
Search this Thread
Quick Reply: PLEASE HELP !!!!!! DIM lights on Odometer / PRND321 Display - 03 Rendezvoux


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.