General Tech Help Good at troubleshooting? Have a non specific issue? Discuss general tech topics here...

2014 Regal GS Code P0303

  #1  
Old 01-05-2019, 06:16 PM
Junior Member
Thread Starter
Join Date: Jan 2019
Posts: 1
Default 2014 Regal GS Code P0303

I have a 2014 Regal GS AWD Turbo and out of the blue today when I gave it gas it hesitates really bad. Check engine light flashes and the traction control light will then come on and then the check engine light goes to solid. (no longer flashes) The code was P0303 is what pulled Cylinder 3 Changed spark plugs and its still doing this. I have purchase coil pack and waiting for this to come in tomorrow. Has anyone had this issue or have any ideas? Has about 8-K miles on it. I am hoping the coil pack will be the fix but I was hoping the spark plugs were the fix too. Thanks for any advise!
 
  #2  
Old 01-10-2019, 04:25 AM
Senior Member
Join Date: Oct 2016
Location: Minot, ME
Posts: 363
Default

Could be fuel injector also. I'd try pulling off plug wire and see if car runs the same or worse. Would think though a continous skipping/misfire would be present and noticeable on motor. Sounds more like the MAF or TPS, interrelated with cylinder 3? Meaning fuel enrichment, timing advance with depressing gas pedal?
 

Last edited by Rich B.; 01-10-2019 at 04:54 AM.
  #3  
Old 02-04-2019, 10:08 AM
Junior Member
Join Date: Feb 2019
Posts: 2
Default Any Update?

Originally Posted by jhjbsmith View Post
I have a 2014 Regal GS AWD Turbo and out of the blue today when I gave it gas it hesitates really bad. Check engine light flashes and the traction control light will then come on and then the check engine light goes to solid. (no longer flashes) The code was P0303 is what pulled Cylinder 3 Changed spark plugs and its still doing this. I have purchase coil pack and waiting for this to come in tomorrow. Has anyone had this issue or have any ideas? Has about 8-K miles on it. I am hoping the coil pack will be the fix but I was hoping the spark plugs were the fix too. Thanks for any advise!

We are having the exact same issue. Did you get the problem fixed yet?
 
  #4  
Old 02-08-2019, 08:47 AM
Junior Member
Join Date: Feb 2019
Posts: 2
Default

A new coil was put on and the issue is gone.
 
  #5  
Old 02-08-2019, 02:58 PM
Senior Member
Join Date: Sep 2010
Posts: 805
Default

Something to think about,
When you pull off a plug wire on an engine with electronic ignition you remove a path for the electricity to go whether it is to a spark plug or to ground.
What happens is, this creates a spike in the ignition electronics and can wipe out a component. So,,,,,,,,,it is not recommended to do so.
The better way to isolate a misfiring cyl would be to provide a path directly to ground instead of through the spark plug..It may be a little extra work, but when done testing , no contribution to the misfire condition.
Also , can unplug coil (with coil on plug ign)
 

Last edited by hanky; 02-08-2019 at 03:04 PM.
  #6  
Old 02-11-2019, 07:16 PM
Junior Member
Join Date: Jul 2017
Posts: 4
Default

I had the very same issue on my 13 Encore.. When the mechanic pulled the coil pack one of the booted connector had separated from the coil. It evidently had been bad long before the car started acting up because there was lots of white corrosion on it. They replaced the coil pack and no issues since.
 
  #7  
Old 02-12-2019, 04:42 PM
Senior Member
Join Date: Oct 2016
Location: Minot, ME
Posts: 363
Default

Roger that on repairs, sounds like exact diagnosis. Hanky has a very good point though about unchecked voltage runaway. Never gave it a thought about cars but that was a big thing to watch out for when trying to transmit radio frequencies without an antenna to load the circuit, things would fry or pop fuses first hopefully. Guess I won't be trying that either, used to be able to do it though. Would even swap plug wires on Jr.'s truck and be damned if the thing would still run with a mild skip (early 80's).
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Buick Forum Editor
News, Updates & Announcements
0
09-09-2013 11:39 AM
Buick Forum Editor
News, Updates & Announcements
0
09-09-2013 10:36 AM
car nut
News, Updates & Announcements
0
09-01-2013 10:15 AM
Buick Forum Editor
News, Updates & Announcements
0
03-27-2013 07:40 AM
Buick Forum Editor
News, Updates & Announcements
0
03-26-2013 11:10 AM


Thread Tools
Search this Thread
Quick Reply: 2014 Regal GS Code P0303


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.