Ignition module, coil, everything all messed up - Buick Forum - Buick Enthusiasts Forums

Go Back  Buick Forum - Buick Enthusiasts Forums > Brand Reviews > Engine & Internal
Reload this Page >

Ignition module, coil, everything all messed up

Engine & Internal Chat about beefing up your engine's insides here...

Ignition module, coil, everything all messed up

Reply

 
 
 
  #1  
Old 11-14-2016, 11:46 AM
Junior Member
Thread Starter
Join Date: Nov 2016
Posts: 1
Default Ignition module, coil, everything all messed up

2 weeks ago my car broke down, I replaced a cracked ignition coil and the ignition control module. No luck. Still no start. Took it to a shop, 641 dollars later they replaced the crank sensor for me. Starts and ran okay for 3 days, now I'm having bad misfire in cylinder 3 and 6. No spark whatsoever. I replaced the already new coil again, still no luck, put another ignition module on, still no luck. Any ideas before I burn this car
 
Reply With Quote
  #2  
Old 07-17-2017, 06:13 AM
Senior Member
Join Date: Oct 2016
Location: Minot, ME
Posts: 294
Default

Originally Posted by Jfinnkma91 View Post
2 weeks ago my car broke down, I replaced a cracked ignition coil and the ignition control module. No luck. Still no start. Took it to a shop, 641 dollars later they replaced the crank sensor for me. Starts and ran okay for 3 days, now I'm having bad misfire in cylinder 3 and 6. No spark whatsoever. I replaced the already new coil again, still no luck, put another ignition module on, still no luck. Any ideas before I burn this car
There's also the camshaft position sensor, maybe the problem to start with? Car may of been torched by now, hmm.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
VanBuren
LeSabre
0
01-20-2015 06:43 PM
iamrabroad
LeSabre
0
11-30-2008 06:54 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory